Wireshark 1.8.x < 1.8.3 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark 1.8 is earlier than 1.8.3. It thus
is affected by the following vulnerabilities :

- A malformed packet can cause the 'DRDA' and 'HSRP'
dissectors to enter an infinite loop, thereby consuming
excessive CPU resources. (CVE-2012-3548, CVE-2012-5237)

- A malformed packet can cause the 'PPP' dissector to
crash the application. (CVE-2012-5238)

- A malformed packet can trigger a buffer overflow in the
'LDP' dissector, which results in an application crash.
(CVE-2012-5240)

See also :

http://www.wireshark.org/security/wnpa-sec-2012-26.html
http://www.wireshark.org/security/wnpa-sec-2012-27.html
http://www.wireshark.org/security/wnpa-sec-2012-28.html
http://www.wireshark.org/security/wnpa-sec-2012-29.html
http://www.wireshark.org/docs/relnotes/wireshark-1.8.3.html

Solution :

Upgrade to Wireshark version 1.8.3 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 62478 ()

Bugtraq ID: 55284
55754

CVE ID: CVE-2012-3548
CVE-2012-5237
CVE-2012-5238
CVE-2012-5240

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now