Apache OpenOffice < 3.4.1 Multiple Heap-Based Buffer Overflows

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a program affected by multiple
heap-based buffer overflow vulnerabilities.

Description :

The version of Apache OpenOffice installed on the remote host is prior
to 3.4.1. It is, therefore, affected by multiple heap-based buffer
overflow vulnerabilities related to XML manifest handling :

- An error exists related to handling the XML tag
hierarchy.

- A boundary error exists when handling the duplication
of certain unspecified XML tags.

- An error exists in the base64 decoder related to XML
export actions.

See also :

http://www.openoffice.org/security/cves/CVE-2012-2665.html
http://blogs.apache.org/OOo/entry/announcing_apache_openoffice_3_41

Solution :

Upgrade to Apache OpenOffice version 3.4.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 61731 ()

Bugtraq ID: 54769

CVE ID: CVE-2012-2665

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now