Apache 2.4.x < 2.4.3 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.4.x running on the
remote host is prior 2.4.3. It is, therefore, affected by the
following vulnerabilities :

- An input validation error exists related to
'mod_negotiation', 'Multiviews' and untrusted uploads
that can allow cross-site scripting attacks.

- An error exists related to 'mod_proxy_ajp' and
'mod_proxy_http' that can allow connections to remain
open. This condition can allow information disclosure
when combined with specially crafted requests.

Note that Nessus did not actually test for these issues, but instead
has relied on the version in the server's banner.

See also :


Solution :

Upgrade to Apache version 2.4.3 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.6
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 61644 ()

Bugtraq ID: 55131

CVE ID: CVE-2012-2687

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now