Adobe AIR 3.x <= 3.3.0.3670 Multiple Vulnerabilities (APSB12-19)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple security vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote
Windows host is 3.3.0.3670 or earlier and is, therefore, reportedly
affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to
code execution. (CVE-2012-4163, CVE-2012-4164,
CVE-2012-4165)

- An integer overflow vulnerability exists that could
lead to code execution. (CVE-2012-4167)

- A cross-domain information leak vulnerability exists.
(CVE-2012-4168)

- A crash can be caused by a logic error involving
multiple dialogs in Firefox. (CVE-2012-4171)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-19.html

Solution :

Upgrade to Adobe AIR 3.4 (3.4.0.2540) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 61624 ()

Bugtraq ID: 55365

CVE ID: CVE-2012-4163
CVE-2012-4164
CVE-2012-4165
CVE-2012-4167
CVE-2012-4168
CVE-2012-4171

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now