Wireshark 1.4.x < 1.4.15 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.4.x before 1.4.15. This
version is affected by the following vulnerabilities :

- The 'DCP ETSI' dissector can attempt a divide by zero
operation leading to an application crash.
(CVE-2012-4285)

- The 'XTP', 'AFP', and 'CTDB' dissectors can be caused
to go into large or infinite loops. (CVE-2012-4288,
CVE-2012-4289, CVE-2012-4290)

- The 'CIP' dissector can be caused to exhaust system
memory. (CVE-2012-4291)

- The 'STUN' dissector can be caused to crash.
(CVE-2012-4292)

- The 'EtherCAT Mailbox' dissector can be caused to
abort. (CVE-2012-4293)

- A buffer overflow exists related to the 'RTPS2'
dissector. (CVE-2012-4296)

See also :

http://www.wireshark.org/security/wnpa-sec-2012-13.html
http://www.wireshark.org/security/wnpa-sec-2012-15.html
http://www.wireshark.org/security/wnpa-sec-2012-17.html
http://www.wireshark.org/security/wnpa-sec-2012-18.html
http://www.wireshark.org/security/wnpa-sec-2012-20.html
http://www.wireshark.org/security/wnpa-sec-2012-21.html
http://www.wireshark.org/security/wnpa-sec-2012-22.html
http://www.wireshark.org/security/wnpa-sec-2012-23.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.15.html

Solution :

Upgrade to Wireshark version 1.4.15 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now