Shockwave Player <= 11.6.5.635 Multiple Memory Corruption Vulnerabilities (APSB12-17)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple memory corruption vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is 11.6.5.635 or earlier and is, therefore, potentially affected by multiple
unspecified memory corruption vulnerabilities.

A remote attacker could exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://www.adobe.com/support/security/bulletins/apsb12-17.html

Solution :

Upgrade to Adobe Shockwave Player 11.6.6.636 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 61536 ()

Bugtraq ID: 55025
55028
55029
55030
55031

CVE ID: CVE-2012-2043
CVE-2012-2044
CVE-2012-2045
CVE-2012-2046
CVE-2012-2047

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now