LibreOffice < 3.5.5 Multiple Heap-Based Buffer Overflows

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by multiple
buffer overflow vulnerabilities.

Description :

A version of LibreOffice prior to 3.5.5 is installed on the remote
Windows host. It is, therefore, reportedly affected by multiple
heap-based buffer overflow vulnerabilities related to XML manifest
handling :

- An error exists related to handling the XML tag
hierarchy.

- A boundary error exists when handling the duplication
of certain unspecified XML tags.

- An error exists in the base64 decoder related to XML
export actions.

See also :

http://www.pre-cert.de/advisories/PRE-SA-2012-05.txt
http://www.securityfocus.com/archive/1/523851/30/0/threaded
http://www.nessus.org/u?bc6741ee
http://www.libreoffice.org/advisories/CVE-2012-2665/

Solution :

Upgrade to LibreOffice version 3.5.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 61432 ()

Bugtraq ID: 54769

CVE ID: CVE-2012-2665

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now