Wireshark 1.6.x < 1.6.9 Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple denial of service vulnerabilities.

Description :

The installed version of Wireshark is 1.6.x before 1.6.9. This
version is affected by the following vulnerabilities :

- An error exists in the 'PPP' dissector that can cause
the application to crash when reading a malformed
packet from either the wire or from a capture file.
(CVE-2012-4048)

- An error exists in the 'NFS' dissector that can cause
the application to consume excessive CPU resources when
reading a malformed packet from either the wire or from
a capture file. (CVE-2012-4049)

See also :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=680056
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7436
http://www.wireshark.org/security/wnpa-sec-2012-11.html
http://www.wireshark.org/security/wnpa-sec-2012-12.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.9.html

Solution :

Upgrade to Wireshark version 1.6.9 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 60117 ()

Bugtraq ID: 54649

CVE ID: CVE-2012-4048
CVE-2012-4049

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now