VLC Media Player < 2.0.2 Ogg_DecodePacket Function OGG File Handling Overflow

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a media player that is affected by a
buffer overflow vulnerability.

Description :

The version of VLC media player installed on the remote host is
earlier than 2.0.2. It is, therefore, reportedly affected by a heap-
based buffer overflow vulnerability.

An error exists in the function 'Ogg_DecodePacket' in the file
'modules/demux/ogg.c' that does not properly validate input and
could allow a heap-based buffer overflow. Opening a specially
crafted file can result in the execution of arbitrary code.

See also :

http://www.videolan.org/vlc/releases/2.0.2.html
http://www.openwall.com/lists/oss-security/2012/07/06/2
http://www.nessus.org/u?7fd6c9da
http://www.securitytracker.com/id?1027224

Solution :

Upgrade to VLC Media Player version 2.0.2 or later. Alternatively,
remove any affected plugin files from VLC's plugins directory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 60049 ()

Bugtraq ID: 54345

CVE ID: CVE-2012-3377

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now