IrfanView JLS Plugin JLS Compressed Image File Handling Overflow

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by a
heap-based buffer overflow vulnerability.

Description :

The version of the IrfanView JLS plugin (Jpeg_LS.dll) library is
earlier than 0.6.4.1. As such, it reportedly is affected by a heap-
based buffer overflow caused by insufficient validation when
processing compressed JLS images. An attacker could exploit this
vulnerability to execute arbitrary code by tricking a user into
opening a specially crafted JLS file.

See also :

http://www.irfanview.com/plugins.htm
http://www.nessus.org/u?d9dd60a1

Solution :

Upgrade the JLS plugin to version 0.6.4.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 60037 ()

Bugtraq ID: 54244

CVE ID: CVE-2012-3585

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now