Winamp < 5.63 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by multiple vulnerabilities.

Description :

The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than
5.63 and is, therefore, reportedly affected by the following
vulnerabilities :

- A memory corruption error exists in 'in_mod.dll'
related to input validation when handling 'Impulse
Tracker' (IT) files.

- Heap-based buffer overflows exist related to
'bmp.w5s' when handling 'BI_RGB' and 'UYVY' data in AVI
files. Processing decompressed TechSmith Screen Capture
Codec (TSCC) data in AVI files can also trigger a heap-
based buffer overflow.

Successful exploitation can allow arbitrary code execution.

See also :

http://forums.winamp.com/showthread.php?t=345684
http://www.winamp.com/help/Version_History

Solution :

Upgrade to Winamp 5.63 (5.6.3.3234) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 59756 ()

Bugtraq ID: 54131

CVE ID: CVE-2012-3889
CVE-2012-3890
CVE-2012-4045

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now