ImageMagick < 6.7.5-8 Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The remote Windows host is running a version of ImageMagick earlier
than 6.7.5-8 and is, therefore, affected by the following
vulnerabilities :

- The fix for CVE-2012-0247 was incomplete. An integer
overflow error still exists and can lead to corrupted
memory and arbitrary code execution when user-supplied
input is not properly validated. (CVE-2012-1185)

- The fix for CVE-2012-0248 was incomplete. An error in
'profile.c' still allows denial of service attacks when
malformed executables are processed. (CVE-2012-1186)

See also :

http://www.openwall.com/lists/oss-security/2012/03/19/5
http://www.imagemagick.org/script/changelog.php
http://www.nessus.org/u?36327a9d
http://www.nessus.org/u?8e40b798

Solution :

Upgrade to ImageMagick version 6.7.5-8 or later. Alternatively, apply
the patches provided by the vendor.

Note that you may need to manually uninstall the vulnerable version
from the system.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 59369 ()

Bugtraq ID: 51957

CVE ID: CVE-2012-1185
CVE-2012-1186

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now