ImageMagick < 6.7.5-1 Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The remote Windows host is running a version of ImageMagick earlier
than 6.7.5-1 and is, therefore, affected by the following
vulnerabilities :

- An integer overflow error exists related to image IFD
and IOP tags. (CVE-2012-0247)

- A parsing error exists related to image IFD and IOP
tags that can allow denial of service attacks.
(CVE-2012-0248)

See also :

http://www.cert.fi/haavoittuvuudet/2012/haavoittuvuus-2012-021.html
http://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=20286
http://www.imagemagick.org/script/changelog.php
http://www.openwall.com/lists/oss-security/2012/02/10/4

Solution :

Upgrade to ImageMagick version 6.7.5-1 or later.

Note that you may need to manually uninstall the vulnerable version
from the system.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 59368 ()

Bugtraq ID: 51957

CVE ID: CVE-2012-0247
CVE-2012-0248

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now