Wireshark 1.6.x < 1.6.8 Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple denial of service vulnerabilities.

Description :

The installed version of Wireshark is 1.6.x before 1.6.8. This
version is affected by the following vulnerabilities :

- Input validation errors exist in the dissectors for
ANSI MAP, ASF, BACapp, Bluetooth HCI, IEEE 802.11,
IEEE 802.3, LTP, and R3 that can allow specially crafted
packets to cause the application to enter infinite or
very large loops making it unavailable. (Issues 6805,
7118, 7119, 7120, 7121, 7122, 7124, 7125)

- An input validation error exists in the DIAMETER
dissector that can allow specially crafted packets to
cause improper memory allocation leading to application
crashes. (Issue 7138)

- An unspecified error can cause the application to crash
due to a memory misalignment. Note, for Windows, this
issue only occurs on the Itanium platform. (Issue 7221)

See also :

http://www.wireshark.org/security/wnpa-sec-2012-08.html
http://www.wireshark.org/security/wnpa-sec-2012-09.html
http://www.wireshark.org/security/wnpa-sec-2012-10.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.8.html

Solution :

Upgrade to Wireshark version 1.6.8 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.4
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 59240 ()

Bugtraq ID: 53651
53652
53653

CVE ID: CVE-2012-2392
CVE-2012-2393
CVE-2012-2394
CVE-2012-3825

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now