Apache OpenOffice < 3.4.0 Multiple Memory Corruption Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a program affected by multiple
memory corruption vulnerabilities.

Description :

The version of Apache OpenOffice installed on the remote host is prior
to 3.4.0. It is, therefore, affected by several memory corruption
issues :

- An integer overflow error exists in 'vclmi.dll' that
could allow heap-based buffer overflows when handling
embedded image objects. (CVE-2012-1149)

- A memory overwrite error exists in 'libwpd' that could
be triggered when processing WordPerfect documents. This
memory overwrite may lead to arbitrary code execution.
(CVE-2012-2149)

- Memory checking errors exist in
'filter/source/msfilter msdffimp.cxx' that could be
triggered when processing PowerPoint graphics records.
These errors could allow denial of service attacks.
(CVE-2012-2334)

See also :

http://www.securityfocus.com/archive/1/522780/30/0/threaded
http://www.openoffice.org/security/cves/CVE-2012-1149.html
http://www.openoffice.org/security/cves/CVE-2012-2149.html
http://www.openoffice.org/security/cves/CVE-2012-2334.html
http://www.openoffice.org/news/aoo34.html

Solution :

Upgrade to Apache OpenOffice version 3.4.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 59191 ()

Bugtraq ID: 53570

CVE ID: CVE-2012-1149
CVE-2012-2149
CVE-2012-2334

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now