LibreOffice < 3.5.3 Multiple Memory Corruption Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.

Synopsis :

The remote host contains an application affected by multiple memory
corruption vulnerabilities.

Description :

A version of LibreOffice prior to 3.5.3 is installed on the remote
Windows host. It is, therefore, reportedly affected by multiple memory
corruption vulnerabilities :

- An integer overflow vulnerability exists in the
graphics object loading code that could allow a remote
attacker to execute arbitrary code or cause an
application crash. (CVE-2012-1149)

- A denial of service vulnerability exists in the
PowerPoint presentation import code. (CVE-2012-2334)

- A memory corruption vulnerability in the code for
handling .RTF files.

See also :

Solution :

Upgrade to LibreOffice version 3.5.3 or greater.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 59180 ()

Bugtraq ID: 53142

CVE ID: CVE-2012-1149

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now