LibreOffice < 3.5.3 Multiple Memory Corruption Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application affected by multiple memory
corruption vulnerabilities.

Description :

A version of LibreOffice prior to 3.5.3 is installed on the remote
Windows host. It is, therefore, reportedly affected by multiple memory
corruption vulnerabilities :

- An integer overflow vulnerability exists in the
graphics object loading code that could allow a remote
attacker to execute arbitrary code or cause an
application crash. (CVE-2012-1149)

- A denial of service vulnerability exists in the
PowerPoint presentation import code. (CVE-2012-2334)

- A memory corruption vulnerability in the code for
handling .RTF files.

See also :

http://shinnai.altervista.org/exploits/SH-016-20120416.html
http://www.nessus.org/u?79f70016

Solution :

Upgrade to LibreOffice version 3.5.3 or greater.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 59180 ()

Bugtraq ID: 53142
53570

CVE ID: CVE-2012-1149
CVE-2012-2334

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now