Shockwave Player <= 11.6.4.634 Multiple Memory Corruption Vulnerabilities (APSB12-13)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple memory corruption vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is 11.6.4.634 or earlier. As such, it is potentially affected by
multiple unspecified memory corruption vulnerabilities.

A remote attacker could exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://seclists.org/fulldisclosure/2012/May/71
http://seclists.org/fulldisclosure/2012/May/72
http://seclists.org/fulldisclosure/2012/May/73
http://www.adobe.com/support/security/bulletins/apsb12-13.html

Solution :

Upgrade to Adobe Shockwave Player 11.6.5.635 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 59047 ()

Bugtraq ID: 53420

CVE ID: CVE-2012-2029
CVE-2012-2030
CVE-2012-2031
CVE-2012-2032
CVE-2012-2033

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now