Wireshark 1.6.x < 1.6.6 Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple denial of service vulnerabilities.

Description :

The installed version of Wireshark is 1.6.x before 1.6.6. This
version is affected by the following vulnerabilities :

- An error exists in the pcap and pcap-ng parsers that
can allow them to crash when reading 'ERF' data.
(Issue 6804)

- An error exists in the IEEE 802.11 dissector that can
cause it to go into an infinite loop. (Issue 6809)

- An error exists in the 'ANSI A' dissector that can allow
it to crash after dereferencing a NULL pointer.
(Issue 6823)

- An error exists in the 'MP2T' dissector that can allow
it to allocate too much memory thus resulting in
crashes. (Issue 6833)

See also :

http://www.wireshark.org/security/wnpa-sec-2012-04.html
http://www.wireshark.org/security/wnpa-sec-2012-05.html
http://www.wireshark.org/security/wnpa-sec-2012-06.html
http://www.wireshark.org/security/wnpa-sec-2012-07.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.6.html

Solution :

Upgrade to Wireshark version 1.6.6 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.4
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 58518 ()

Bugtraq ID: 52735
52736
52737
52738

CVE ID: CVE-2012-1593
CVE-2012-1594
CVE-2012-1595
CVE-2012-1596

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now