IrfanView < 4.32 Buffer Overflow

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

An application on the remote Windows host is affected by a buffer
overflow vulnerability.

Description :

The remote Windows host contains a version of IrfanView earlier than
4.32. As such, it is reportedly affected by a buffer overflow
vulnerability due to the way the application handles TIFF files with
SGILog compressed images fixed.

A remote, unauthenticated attacker could exploit this flaw to execute
arbitrary code on the remote host subject to the privileges of the
user running the affected application.

See also :

http://www.irfanview.com/main_history.htm
http://www.irfanview.com/history_old.htm

Solution :

Upgrade to IrfanView version 4.32 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 57560 ()

Bugtraq ID: 51132

CVE ID: CVE-2011-5233

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now