Wireshark 1.6.x < 1.6.5 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.6.x before 1.6.5. This
version is affected by the following vulnerabilities :

- Errors exist in the parsers for '5views', 'i4b',
'iptrace', 'netmon2' and 'novell' packets that can lead
to application crashes. (Issues #6663, 6666, 6667,
6668, 6669, 6670)

- An unspecified error exists in the display processing
of certain packets that can lead to a NULL pointer
dereference. (Issue #6634)

- A buffer overflow exists in the 'RLC' dissector.
(Issue #6391)

See also :

http://www.wireshark.org/security/wnpa-sec-2012-01.html
http://www.wireshark.org/security/wnpa-sec-2012-02.html
http://www.wireshark.org/security/wnpa-sec-2012-03.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.5.html
http://www.securityfocus.com/data/vulnerabilities/exploits/51710.zip

Solution :

Upgrade to Wireshark version 1.6.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 57539 ()

Bugtraq ID: 51368
51710

CVE ID: CVE-2012-0041
CVE-2012-0042
CVE-2012-0043
CVE-2012-0066
CVE-2012-0067
CVE-2012-0068

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now