OpenSSL 1.x < 1.0.0f Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple SSL-related

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.x that is earlier than 1.0.0f. Such versions are affected
by the following vulnerabilities :

- The Datagram Transport Layer Security (DTLS)
implementation is vulnerable to plaintext recovery
attacks when decrypting in CBC mode. (CVE-2011-4108)

- An error exists related to SSLv3.0 records that can
lead to disclosure of uninitialized memory because the
library does not clear all bytes used as block cipher
padding. (CVE-2011-4576)

- An error exists related to RFC 3779 processing that can
allow denial of service attacks. Note that this
functionality is not enabled by default and must be
configured at compile time via the 'enable-rfc3779'
option. (CVE-2011-4577)

- An error exists related to handshake restarts for
server gated cryptography (SGC) that can allow denial
of service attacks. (CVE-2011-4619)

- An error exists in the GOST implementation that can
allow invalid GOST parameters to crash the server.

See also :

Solution :

Upgrade to OpenSSL 1.0.0f or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 57460 ()

Bugtraq ID: 51281

CVE ID: CVE-2011-4108

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now