OpenSSL < 0.9.8s Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server has multiple SSL-related vulnerabilities.

Description :

According to its banner, the remote web server is running a version
of OpenSSL older than 0.9.8s. Such versions have the following
vulnerabilities :

- An error exists related to ECDSA signatures and binary
curves. The implementation of curves over binary fields
could allow a remote, unauthenticated attacker to
determine private key material via timing attacks.

- The Datagram Transport Layer Security (DTLS)
implementation is vulnerable to plaintext recovery
attacks when decrypting in CBC mode. (CVE-2011-4108)

- A double-free error exists during a policy check
failure if the flag 'X509_V_FLAG_POLICY_CHECK' is set.

- An error exists related to SSLv3.0 records that can
lead to disclosure of uninitialized memory because the
library does not clear all bytes used as block cipher
padding. (CVE-2011-4576)

- An error exists related to RFC 3779 processing that can
allow denial of service attacks. Note that this
functionality is not enabled by default and must be
configured at compile time via the 'enable-rfc3779'
option. (CVE-2011-4577)

- An error exists related to handshake restarts for
server gated cryptography (SGC) that can allow denial
of service attacks. (CVE-2011-4619)

See also :

Solution :

Upgrade to OpenSSL 0.9.8s or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 6.9
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 57459 ()

Bugtraq ID: 51281

CVE ID: CVE-2011-1945

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now