SuSE 11.1 Security Update : openswan (SAT Patch Number 5424)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 11 host is missing one or more security updates.

Description :

openswan's crypto helper was prone to an use-after-free flaw which
could potentially allow remote attackers to cause a Denial of Service
(CVE-2011-4073, bnc#727002). Additionally, the following issues have
been fixed :

- AH handshake problems (bnc#713986),

- potential dereference of no longer valid pointers,

- mode handling issues

See also :

https://bugzilla.novell.com/show_bug.cgi?id=713986
https://bugzilla.novell.com/show_bug.cgi?id=727002
http://support.novell.com/security/cve/CVE-2011-4073.html

Solution :

Apply SAT patch number 5424.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 57125 ()

Bugtraq ID:

CVE ID: CVE-2011-4073

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now