Foxit Reader < 5.1.3.1201 Memory Corruption RCE

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by a remote code
execution vulnerability.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 5.1.3.1201. It is, therefore, affected by a memory corruption
issue due to a cross-border assignment of an array when opening a
specially crafted PDF file. An attacker can exploit this, by tricking
a user into opening a crafted PDF file, to execute arbitrary code with
the user's privileges.

See also :

https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=235

Solution :

Upgrade to Foxit Reader version 5.1.3.1201 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 57050 ()

Bugtraq ID: 50947

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now