OpenSSL < 0.9.8h Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server has multiple SSL-related vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL older than 0.9.8h. As such, it may be affected by the
following vulnerabilities :

- A double-free error exists related to the handling of
server name extension data and specially crafted TLS
1.0 'Client Hello' packets. This can cause application
crashes. Note that successful exploitation requires that
OpenSSL is compiled with the TLS server name extensions.

- A NULL pointer dereference error exists related to
anonymous Diffie-Hellman key exchange and TLS
handshakes. This can be exploited by omitting the
'Server Key exchange message' from the handshake and
can cause application crashes. (CVE-2008-1672)

- On 32-bit builds, an information disclosure
vulnerability exists during certain calculations for
NIST elliptic curves P-256 or P-384. This error can
allow an attacker to recover the private key of the TLS

The following are required for exploitation :

- 32-bit build
- Use of elliptic curves P-256 and/or P-384
- Either the use of ECDH family ciphers and/or the
use of ECDHE family ciphers without the
SSL_OP_SINGLE_ECDH_USE context option


Note that Nessus has not attempted to verify that these issues are
actually exploitable or have been patched but instead has relied on
the version number found in the Server response header.

See also :

Solution :

Upgrade to OpenSSL 0.9.8h or later or apply the vendor-supplied

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 56996 ()

Bugtraq ID: 29405

CVE ID: CVE-2008-0891

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now