Adobe AIR <= 3.0 Multiple Vulnerabilities (APSB11-28)

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR installed on the
remote Windows host is 3.0 or earlier and is reportedly affected by
several critical vulnerabilities :

- Several unspecified memory corruption errors
exist that could lead to code execution.
(CVE-2011-2445, CVE-2011-2451, CVE-2011-2452,
CVE-2011-2453, CVE-2011-2454, CVE-2011-2455,
CVE-2011-2459, CVE-2011-2460)

- An unspecified heap corruption error exists that could
lead to code execution. (CVE-2011-2450)

- An unspecified buffer overflow error exists that could
lead to code execution. (CVE-2011-2456)

- An unspecified stack overflow error exists that could
lead to code execution. (CVE-2011-2457)

- An unspecified error related to Internet Explorer can
allow cross-domain policy violations. (CVE-2011-2458)

By tricking a user on the affected system into opening a specially
crafted document with Flash content, an attacker could leverage these
vulnerabilities to execute arbitrary code remotely on the system
subject to the user's privileges.

See also :

http://www.adobe.com/support/security/bulletins/apsb11-28.html

Solution :

Upgrade to Adobe AIR 3.1 (3.1.0.4880) or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now