Fedora 15 : phpMyAdmin-3.4.7-1.fc15 (2011-15469)

This script is Copyright (C) 2011-2015 Tenable Network Security, Inc.


Synopsis :

The remote Fedora host is missing a security update.

Description :

Changes for 3.4.7.0 (2011-10-23);

- [interface] Links in navigation when
$cfg['MainPageIconic'] =3D false

- [interface] Inline edit shows dropdowns even after
closing

- [view] View renaming did not work

- [navi] Wrong icon for view (MySQL 5.5)

- [doc] Missing documentation section

- [pdf] Broken PDF file when exporting database to PDF

- [core] Allow to set language in URL

- [doc] Fix links to PHP documentation

- [export] Export to bzip2 is not working

Changes for 3.4.6.0 (2011-10-16) :

- [patch] InnoDB comment display with tooltips/aliases

- [navi] Edit SQL statement after error

- [interface] Collation not displayed for long enum
fields

- [export] Config for export compression not used

- [privileges] DB-specific privileges won't submit

- [config] Configuration storage incorrect suggested
table name

- [interface] Cannot execute saved query

- [display] Full text button unchecks results display
options

- [display] Broken binary column when 'Show binary
contents' is not set

- [core] Call to undefined function PMA_isSuperuser()

- [interface] Display options link missing after search

- [core] CSP policy causing designer JS buttons to fail

- [relation] Relations/constraints are dropped/created
on every change

- [display] Delete records from last page breaks search

- [schema] PMA_User_Schema::processUserChoice() is
broken

- [core] External link fails in 3.4.5

- [display] CharTextareaRows is not respected

- [synchronize] Extraneous db choices

- [security] Fixed local path disclosure vulnerability,
see PMASA-2011-15=
(http://www.phpmyadmin.net/home_page/security/PMASA-20
11-15.php)

- [security] Fixed XSS in setup (host/verbose parameter),
see PMASA-2011-= 16
(http://www.phpmyadmin.net/home_page/security/PMASA-2011
-16.php)
--------------------------------------------------------
-------------------=

Note that Tenable Network Security has extracted the preceding
description block directly from the Fedora security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

http://www.phpmyadmin.net/home_page/security/PMASA-2011-15.php
http://www.phpmyadmin.net/home_page/security/PMASA-2011-16.php
https://bugzilla.redhat.com/show_bug.cgi?id=746880
http://www.nessus.org/u?1e5fda7b

Solution :

Update the affected phpMyAdmin package.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)

Family: Fedora Local Security Checks

Nessus Plugin ID: 56798 ()

Bugtraq ID:

CVE ID: CVE-2011-3646
CVE-2011-4064

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now