Firefox 3.6 < 3.6.24 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains a web browser that is potentially
affected by multiple vulnerabilities.

Description :

The installed version of Firefox 3.6 is earlier than 3.6.24. Such
versions are potentially affected by the following security issues :

- There is an error within the JSSubScriptLoader that
incorrectly unwraps 'XPCNativeWrappers'. By tricking
a user into installing a malicious plug-in, an attacker
could exploit this issue to execute arbitrary code.

- Certain invalid sequences are not handled properly in
'Shift-JIS' encoding, which can allow cross-site
scripting attacks. (CVE-2011-3648)

- Profiling JavaScript files with many functions can cause
the application to crash. It may be possible to trigger
this behavior even when the debugging APIs are not being
used. (CVE-2011-3650)

See also :

Solution :

Upgrade to Firefox 3.6.24 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 56755 ()

Bugtraq ID: 50589

CVE ID: CVE-2011-3647

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now