Apache 2.2.x < 2.2.21 mod_proxy_ajp DoS

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by a denial of service

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.21. It is, therefore, potentially affected
by a denial of service vulnerability. An error exists in the
'mod_proxy_ajp' module that can allow specially crafted HTTP requests
to cause a backend server to temporarily enter an error state. This
vulnerability only occurs when 'mod_proxy_ajp' is used along with

Note that Nessus did not actually test for the flaws but instead has
relied on the version in the server's banner.

See also :


Solution :

Upgrade to Apache version 2.2.21 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 56216 ()

Bugtraq ID: 49616

CVE ID: CVE-2011-3348

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now