Wireshark 1.6.x < 1.6.2 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.6.x before 1.6.2. This
version is affected by the following vulnerabilities :

- An error exists in IKE dissector that can allow denial
of service attacks when processing certain malformed
packets. (CVE-2011-3266)

- A buffer exception handling vulnerability exists that
can allow denial of service attacks when processing
certain malformed packets. (Issue #6135)

- It may be possible to make Wireshark execute Lua scripts
using a method similar to DLL hijacking. (Issue #6136)

- An error exists in OpenSafety dissector that can allow
denial of service attacks when processing certain
malformed packets. (Issue #6138)

- An error exists in CSN.1 dissector that can allow denial
of service attacks when processing certain malformed
packets. (Issue #6139)

See also :

http://www.wireshark.org/security/wnpa-sec-2011-12.html
http://www.wireshark.org/security/wnpa-sec-2011-13.html
http://www.wireshark.org/security/wnpa-sec-2011-14.html
http://www.wireshark.org/security/wnpa-sec-2011-15.html
http://www.wireshark.org/security/wnpa-sec-2011-16.html
http://www.wireshark.org/docs/relnotes/wireshark-1.6.2.html

Solution :

Upgrade to Wireshark version 1.6.2 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 56164 ()

Bugtraq ID: 49377
49521
49522
49524
49528

CVE ID: CVE-2011-3266
CVE-2011-3360
CVE-2011-3482
CVE-2011-3483
CVE-2011-3484

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now