OpenSSL 1.x < 1.0.0e Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple SSL-related

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.x prior to 1.0.0e. It is, therefore, affected by the
following vulnerabilities :

- An error exists related to ECDSA signatures and binary
curves. The implementation of curves over binary fields
could allow a remote, unauthenticated attacker to
determine private key material via timing attacks.

- An error exists in the internal certificate verification
process that can allow improper acceptance of a
certificate revocation list (CRL) if the list's
'nextUpdate' field contains a date in the past. Note
that this internal CRL checking is not enabled by
default. (CVE-2011-3207)

- An error exists in the code for the ephemeral
(EC)DH cipher suites that can allow a remote attacker to
crash the process. (CVE-2011-3210)

See also :

Solution :

Upgrade to OpenSSL 1.0.0e or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 56162 ()

Bugtraq ID: 47888

CVE ID: CVE-2011-1945

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now