VLC Media Player 0.5.0 to 1.1.10 Multiple Buffer Overflows

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a media player that can allow code

Description :

The version of VLC media player installed on the remote host is
between 0.5.0 and 1.1.10. As such, it is reportedly affected by
multiple vulnerabilities:

- An integer overflow error exists in the handling of
the RealAudio portions of RealMedia files.

- An integer underflow error exists in the handling of
'strf' portions of AVI files. (VideoLAN-SA-1106)

Exploiting these vulnerabilities can lead to application crashes and
possibly code execution through heap-based buffer overflows.

See also :


Solution :

Upgrade to VLC Media Player version 1.1.11 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 55608 ()

Bugtraq ID: 48664

CVE ID: CVE-2011-2587

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now