VLC Media Player 0.5.0 to 1.1.10 Multiple Buffer Overflows

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a media player that can allow code
execution.

Description :

The version of VLC media player installed on the remote host is
between 0.5.0 and 1.1.10. As such, it is reportedly affected by
multiple vulnerabilities:

- An integer overflow error exists in the handling of
the RealAudio portions of RealMedia files.
(VideoLAN-SA-1105)

- An integer underflow error exists in the handling of
'strf' portions of AVI files. (VideoLAN-SA-1106)

Exploiting these vulnerabilities can lead to application crashes and
possibly code execution through heap-based buffer overflows.

See also :

http://www.videolan.org/security/sa1105.html
http://www.videolan.org/security/sa1106.html

Solution :

Upgrade to VLC Media Player version 1.1.11 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 55608 ()

Bugtraq ID: 48664

CVE ID: CVE-2011-2587
CVE-2011-2588

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now