Apache 2.2.x < 2.2.18 APR apr_fnmatch DoS

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server may be affected by a denial of service

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is 2.2.18. It is, therefore, affected by a denial of
service vulnerability due to an error in the fnmatch implementation in
'apr_fnmatch.c' in the bundled Apache Portable Runtime (APR) library.

Successful exploitation of this vulnerability requires that
'mod_autoindex' be enabled.

Note that the remote web server may not actually be affected by this
vulnerability. Nessus did not try to determine whether the affected
module is in use or to check for the issue itself.

See also :


Solution :

Upgrade to Apache version 2.2.19 or later. Alternatively, ensure that
the 'IndexOptions' configuration option is set to 'IgnoreClient'.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.6
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 54646 ()

Bugtraq ID: 47929

CVE ID: CVE-2011-1928

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now