openSUSE Security Update : moodle (openSUSE-SU-2010:0937-1)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update of moodle fixes :

- CVE-2010-4207: CVSS v2 Base Score: 4.3 (MEDIUM)
(AV:N/AC:M/Au:N/C:N/I:P/A:N): Cross-Site Scripting (XSS)
(CWE-79) Cross-site scripting vulnerability in the Flash
component infrastructure in YUI allows remote attackers
to inject arbitrary web script or HTML via
charts/assets/charts.swf.

- CVE-2010-4208: CVSS v2 Base Score: 4.3 (MEDIUM)
(AV:N/AC:M/Au:N/C:N/I:P/A:N): Cross-Site Scripting (XSS)
(CWE-79) Cross-site scripting vulnerability in the Flash
component infrastructure in YUI allows remote attackers
to inject arbitrary web script or HTML via
uploader/assets/uploader.swf.

- CVE-2010-4209: CVSS v2 Base Score: 4.3 (MEDIUM)
(AV:N/AC:M/Au:N/C:N/I:P/A:N): Cross-Site Scripting (XSS)
(CWE-79) Cross-site scripting vulnerability in the Flash
component infrastructure in YUI allows remote attackers
to inject arbitrary web script or HTML via
swfstore/swfstore.swf.

See also :

http://lists.opensuse.org/opensuse-updates/2010-11/msg00014.html
https://bugzilla.novell.com/show_bug.cgi?id=650155

Solution :

Update the affected moodle packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: SuSE Local Security Checks

Nessus Plugin ID: 53681 ()

Bugtraq ID:

CVE ID: CVE-2010-4207
CVE-2010-4208
CVE-2010-4209

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now