Wireshark < 1.2.16 / 1.4.5 Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.2.x less than 1.2.16 or 1.4.x
less than 1.4.5. Such versions are affected by the following
vulnerabilities :

- A data type mismatch error exists in the function
'dissect_nfs_clientaddr4' in the file 'packet-nfs.c' of
the NFS dissector and could lead to application crashes
while decoding 'SETCLIENTID' calls. (5209)

- A use-after-free error exists in the file
'asn1/x509if/x509if.cnf' of the X.509if dissector that
could lead to application crashes. (5754, 5793)

- An buffer overflow vulnerability exists in the file
'packet-dect.c' of the DECT dissector that could allow
arbitrary code execution. (5836)

See also :

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5209
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5754
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5793
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5836
http://www.wireshark.org/security/wnpa-sec-2011-05.html
http://www.wireshark.org/security/wnpa-sec-2011-06.html
http://www.wireshark.org/docs/relnotes/wireshark-1.2.16.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.5.html

Solution :

Upgrade to Wireshark version 1.2.16 / 1.4.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 53473 ()

Bugtraq ID: 47392

CVE ID: CVE-2011-1590
CVE-2011-1591
CVE-2011-1592

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now