VLC Media Player < 1.1.9 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a media player that is affected by
multiple vulnerabilities.

Description :

The version of VLC media player installed on the remote host is
earlier than 1.1.9. Such versions are affected by multiple
vulnerabilities:

- A heap based buffer overflow exists in the function
'MP4_ReadBox_skcr' in 'modules/demux/mp4/libmp4.c'.
This issue can be triggered when parsing of a
malicious MP4 file and lead to application crashes and
possibly arbitrary code execution.

- An unspecified error exists in the third-party
libmodplug component included with VLC.

See also :

http://www.videolan.org/vlc/releases/1.1.9.html
http://www.videolan.org/security/sa1103.html

Solution :

Upgrade to VLC Media Player version 1.1.9 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 53405 ()

Bugtraq ID: 47293

CVE ID: CVE-2011-1684

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now