Wireshark < 1.2.15 / 1.4.4 Multiple Vulnerabilities

This script is Copyright (C) 2011-2015 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.0.x or 1.2.x less than 1.2.15
or 1.4.x less than 1.4.4. Such versions are affected by the following
vulnerabilities :

- The BER dissector may loop indefinitely. (Bug #1516)

- A crash can occur in the NTLMSSP dissector. (Bug #5157)

- An error exists in the processing of pcap-ng files
that causes the application to free an uninitialized
pointer. (Bug #5652)

- An error exists in the processing of packets having
large length in a pcap-ng file. This can result in
application crashes. (Bug #5661)

- A stack overflow vulnerability exists in the LDAP and
SMB dissectors. (Bug #5717)

- An error exists in the processing of malformed 6LoWPAN
packets. This affects only 32-bit platforms and can
result in application crashes. (Bug #5722)

- An error exists in the processing of large LDAP filter
strings that cause the application to consume excessive
amounts of memory. (Bug #5732)

See also :


Solution :

Upgrade to Wireshark version 1.2.15 / 1.4.4 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now