Apache Tomcat 6.0.x < 6.0.30 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.0.x listening on the remote host is prior to 6.0.30. It is,
therefore, affected by multiple vulnerabilities :

- An error in the access restriction on a 'ServletContext'
attribute that holds the location of the work directory
in Tomcat's SecurityManager. A malicious web application
can modify the location of the working directory which
then allows improper read and write access to arbitrary
files and directories in the context of Tomcat.

- An input validation error exists in the Manager
application in that it fails to filter the 'sort' and
'orderBy' input parameters. (CVE-2010-4172)

- An input validation error exists in the HTML manager
application in that it fails to filter various input
data before returning it to the browser. (CVE-2011-0013)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Update Apache Tomcat to version 6.0.30 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.4
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 51975 ()

Bugtraq ID: 45015

CVE ID: CVE-2010-3718

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now