FreeBSD : awstats -- arbitrary commands execution vulnerability (ce6ce2f8-34ac-11e0-8103-00215c6a37bb)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Awstats change log reports :

- Security fix (Traverse directory of LoadPlugin)

- Security fix (Limit config to defined directory to avoid access to
external config file via a nfs or webdav link).

See also :

http://www.exploitdevelopment.com/Vulnerabilities/2010-WEB-001.html
http://awstats.sourceforge.net/docs/awstats_changelog.txt
http://www.nessus.org/u?f4009315

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 51930 ()

Bugtraq ID:

CVE ID: CVE-2010-4367

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now