Flash Player < 10.2.152.26 Multiple Vulnerabilities (APSB11-02)

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a browser plug-in that is affected
by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe Flash Player
earlier than 10.2.152.26. Such versions are potentially affected by
multiple vulnerabilities :

- An integer overflow exists that could lead to code
execution. (CVE-2011-0558)

- Multiple memory corruption vulnerabilities exist that
could lead to code execution. (CVE-2011-0559,
CVE-2011-0560, CVE-2011-0561, CVE-2011-0571,
CVE-2011-0572, CVE-2011-0573, CVE-2011-0574,
CVE-2011-0578, CVE-2011-0607, CVE-2011-0608)

- A library-loading vulnerability exists that could lead
to code execution. (CVE-2011-0575)

- A font-parsing vulnerability exists that could lead to
code execution. (CVE-2011-0577)

See also :

http://www.adobe.com/support/security/bulletins/apsb11-02.html

Solution :

Upgrade to Flash Player 10.2.152.26 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now