Mandriva Linux Security Advisory : postgresql (MDVSA-2011:021)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability was discovered and corrected in postgresql :

Buffer overflow in the gettoken function in
contrib/intarray/_int_bool.c in the intarray array module in
PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before
8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to
cause a denial of service (crash) and possibly execute arbitrary code
via integers with a large number of digits to unspecified functions
(CVE-2010-4015).

Packages for 2009.0 are provided as of the Extended Maintenance
Program. Please visit this link to learn more:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

This update provides a solution to this vulnerability.

See also :

http://www.postgresql.org/support/security

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Mandriva Local Security Checks

Nessus Plugin ID: 51898 ()

Bugtraq ID: 46084

CVE ID: CVE-2010-4015

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now