VLC Media Player < 1.1.7 MKV Input Validation Vulnerability

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an media player that is affected by
a code execution vulnerability.

Description :

The version of VLC media player installed on the remote host is
earlier than 1.1.7. Such versions are reportedly affected by the
following vulnerability :

- Insufficient input validation when parsing a specially
crafted Matroska or WebM (MKV) file can be exploited to
execute arbitrary code.

See also :

http://www.videolan.org/security/sa1102.html
http://www.videolan.org/developers/vlc-branch/NEWS

Solution :

Upgrade to VLC Media Player version 1.1.7 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 51851 ()

Bugtraq ID: 46060

CVE ID: CVE-2011-0531

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now