Adobe Photoshop CS5 < 12.0.2 (APSB10-30)

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has an application that is affected by
unspecified vulnerabilities.

Description :

The installed version of Adobe Photoshop is older than 12.0.2, and
hence affected by the following issues :

- Insecure library loading, which could result in
arbitrary code execution. (CVE-2010-3127)

- Multiple unspecified vulnerabilities.

See also :

http://www.adobe.com/support/security/bulletins/apsb10-30.html
http://www.adobe.com/support/downloads/detail.jsp?ftpID=4893
http://www.adobe.com/support/downloads/detail.jsp?ftpID=4949

Solution :

Apply Adobe Photoshop 12.0.2 update or later.

Although version 12.0.2 is considered non-vulnerable, Adobe
recommends upgrading to 12.0.3 or later. Version 12.0.3
reportedly fixes high priority, non-security related bugs.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 51189 ()

Bugtraq ID: 45359
45492

CVE ID: CVE-2010-3127

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now