Mozilla Thunderbird 3.1.x < 3.1.7 Multiple Vulnerabilities

This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a mail client that is affected by
multiple vulnerabilities.

Description :

The installed version of Thunderbird is earlier than 3.1.x < 3.1.7.
Such versions are potentially affected by multiple vulnerabilities :

- Multiple memory corruption issues could lead to
arbitrary code execution.(MFSA 2010-74)

- On the Windows platform, when 'document.write()' is
called with a very long string, a buffer overflow could
be triggered. (MFSA 2010-75)

- Downloadable fonts could expose vulnerabilities in the
underlying OS font code. (MFSA 2010-78)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2010-74/
https://www.mozilla.org/en-US/security/advisories/mfsa2010-75/
https://www.mozilla.org/en-US/security/advisories/mfsa2010-78/
http://www.nessus.org/u?2dec7d97

Solution :

Upgrade to Thunderbird 3.1.7 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 51123 ()

Bugtraq ID: 45344
45345
45347
45348
45352

CVE ID: CVE-2010-3768
CVE-2010-3769
CVE-2010-3776
CVE-2010-3777
CVE-2010-3778

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now