Wireshark < 1.2.12 / 1.4.1 ASN.1 BER Dissector Denial of Service

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is vulnerable to
a denial of service attack.

Description :

The installed version of Wireshark is 1.2.x less than 1.2.12 or 1.4.x
less than 1.4.1. Such versions are affected by a denial of service
vulnerability. The ASN.1 BER dissector contains a flaw that can allow
a stack overflow that in turn can cause the application to crash.

See also :

http://seclists.org/bugtraq/2010/Sep/87
http://www.wireshark.org/security/wnpa-sec-2010-11.html
http://www.wireshark.org/security/wnpa-sec-2010-12.html

Solution :

Upgrade to Wireshark version 1.2.12 / 1.4.1 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 49978 ()

Bugtraq ID: 43197

CVE ID: CVE-2010-3445

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now