Foxit Reader < 4.2.0.0928 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by multiple
vulnerabilities.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 4.2.0.0928. It is, therefore, affected by multiple
vulnerabilities :

- A stack buffer overflow condition exists due to improper
sanitization of the file title. An attacker can exploit
this, via a specially crafted PDF document containing an
overly long title, to execute arbitrary code.

- An identity verification vulnerability exists related to
how digital signatures in a document are validated. An
attacker can exploit this to falsify documents.

See also :

http://pdfsig-collision.florz.de/
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=200

Solution :

Upgrade to Foxit Reader version 4.2.0.0928 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 49780 (foxit_reader_4_2_0_928.nasl)

Bugtraq ID: 43785

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now