openSUSE Security Update : bzip2 (openSUSE-SU-2010:0684-1)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes an integer overflow in the BZ2_decompress function
of bzip2/libbz2. This can be exploited via a crafted archive to cause
a denial of service or even execute arbitrary code. (CVE-2010-0405)

See also :

http://lists.opensuse.org/opensuse-updates/2010-09/msg00058.html
https://bugzilla.novell.com/show_bug.cgi?id=636978

Solution :

Update the affected bzip2 packages.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 49753 ()

Bugtraq ID:

CVE ID: CVE-2010-0405

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now