openSUSE Security Update : cifs-mount (openSUSE-SU-2010:0658-1)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

A buffer overflow in the sid_parse() function of samba could
potentially be exploited by remote attackers to execute arbitrary code
(CVE-2010-3069).

Additionally the update also contains fixes for the following
non-security issues: bnc#567013 - Failed to join ADS Domain bnc#592198
- Samba 3.0 / 3.2 doesn't work with Windows 2008 R2 (NTLMv2)
bnc#599873 - Problem using NTLM authentication with 2008R2 bnc#613459
- winbindd crashes in rpccli_set_timeout bnc#617153 - new printers are
not seen in samba with registry

See also :

http://lists.opensuse.org/opensuse-updates/2010-09/msg00043.html
https://bugzilla.novell.com/show_bug.cgi?id=567013
https://bugzilla.novell.com/show_bug.cgi?id=583535
https://bugzilla.novell.com/show_bug.cgi?id=592198
https://bugzilla.novell.com/show_bug.cgi?id=599873
https://bugzilla.novell.com/show_bug.cgi?id=613459
https://bugzilla.novell.com/show_bug.cgi?id=617153
https://bugzilla.novell.com/show_bug.cgi?id=637218

Solution :

Update the affected cifs-mount packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 49667 ()

Bugtraq ID:

CVE ID: CVE-2010-3069

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now