Foxit Reader < 4.1.1.0805 FreeType CFF Opcodes RCE

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by a remote code
execution vulnerability.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 4.1.1.0805. It is, therefore, affected by a remote code
execution vulnerability in the FreeType engine due to multiple
stack-based buffer overflow conditions in the CFF Type2 CharStrings
interpreter, specifically within the function
cff_decoder_parse_charstrings(). An attacker can exploit this, via
crafted CFF opcodes in embedded fonts in a PDF document, to cause a
denial of service or to execute arbitrary code with the user's
privileges.

See also :

http://www.f-secure.com/weblog/archives/00002002.html
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=194

Solution :

Upgrade to Foxit Reader version 4.1.1.0805 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 48276 (foxit_reader_4_1_1_0805.nasl)

Bugtraq ID: 42241

CVE ID: CVE-2010-1797

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now