Apache Tomcat 6.0 < 6.0.28 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat server is affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.0 listening on the remote host is prior to 6.0.28. It is,
therefore, affected by multiple vulnerabilities:

- If a web app is configured to use BASIC or DIGEST
authentication and the 'realm-name' attribute is not
configured in that web app's 'web.xml' file, the remote
server's hostname or IP will be included in replies.

- An error exists in the handling of invalid values in
the 'Transfer-Encoding' header of a request. An attacker
can exploit this to cause a denial of service or to
disclose sensitive information. (CVE-2010-2227)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Tomcat version 6.0.28 or later.

Risk factor :

Medium / CVSS Base Score : 6.4
CVSS Temporal Score : 5.3
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 48255 ()

Bugtraq ID: 41544

CVE ID: CVE-2010-2227

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now